Content Security Policy WordPress Plugin

The Content Security Policy server logic has been implemented for WordPress as a plugin. Download it here:

http://wordpress.org/extend/plugins/content-security-policy/

The CSP WordPress plugin adds a menu page to the WordPress Administration Panel that allows a user to enable Content Security Policy on the content portion of their site and provides a simple interface for tailoring the policy to the individual site.

  • Policy Recomendation - the CSP admin page can scan your WordPress installation to analyze the sources and types of content in use to provide a recommended policy for the site:


    Policy Recommendation

  • New Script via Editor - the plugin adds a "Script" type to the "Add Media" dialog allowing users to create new script files via a simple web form. The new files are placed in the uploads section of the site for easy insertion into posts:


    Easily Add Script Files

Give the new plugin a try and let us know what you think.

Overview | Details | Spec | Download | Demo | WordPress | Origin Header | Discussion